Sharefile - PDF will not open with Adobe
https://support.citrix.com/article/CTX296583
CTX296583
"Access Denied" when opening PDFs from Citrix Files through Adobe products
Article | 4 found this helpful | Created: 10 Feb 2021 | Modified: 11 Feb 2021
Symptoms or Error
- Get error "Access denied" when trying to open PDFs from the mounted Citrix Files drive.
- File can be copied to desktop and opens fine on Adobe products from there.
- File can be opened in a different PDF reader from Citrix Files for Windows
- Citrix Files logs show an error similar to this:
[WINFSP] Unable to create the file \(temp file name).tmp -->ShareFile.Client.Windows.Cbfs.Exceptions.PermissionDeniedException: [FUSE] Cannot create folder: \(temp file name).tmp
Solution
Workaround: Disable Protected Mode on Startup (Reader) or Protected View on Startup (Pro).
Official information for Protected Mode is available here: https://helpx.adobe.com/acrobat/kb/protected-mode-troubleshooting-reader.html
From the article, to disable:
- Disable Protected Mode by going to Edit > Preferences > General and deselecting Enable Protected Mode at startup.
- Restart Reader.
Official information for Protected View is available here: https://helpx.adobe.com/acrobat/using/protected-view-feature-pdfs-windows.html
From the article, to disable:
- Choose Preferences.
- From the Categories on the left, select Security (Enhanced).
- Select the Enable Enhanced Security option "Off".
Problem Cause
Protected Mode and Protected View interact poorly with content on mounted drives. Citrix is receiving reports from customers that the latest update seems to have set Protected View to on by default.
The planned update for both Adobe Acrobat Pro and Adobe Reader was scheduled on February 9th, 2021, according to the following link:
https://www.adobe.com/devnet-docs/acrobatetk/tools/ReleaseNotesDC/continuous/dccontinuousfeb2021.html